Cannot find users list

Started by DezB, April 29, 2009, 02:17:25 AM

DezB

Hi Folks

I have just installed everything on a test site but when I try to log in to view a protected page I get the error "Cannot find users list!"

It must be something simple I have missed, any suggestions please?

Many thanks

DezB

Peiatro

On login.php,

change line 13 to:


$users = @file('***YOUR URL HERE ***/users.php' . USERS_LIST_FILE);


P

DezB

Hi Peiatro

Thanks for the info, unfortunately it did not work. 

I've tried everything that I can find in the forum relating to this error but again, no joy.

I uploaded all the files into a folder on the server called "protect" and changed the settings.php to read: define('USERS_LIST_FILE', 'protect/users.php'); and also set the file permissions on protect/users.php to 777

If I log into the manager I can see the new username and password ok and have changed the link on the homepage to hidden/pagename.php with the string from the manager.php added to the first line after the body tag, is this correct?

Any other ideas??  I've not got much hair as it is....

Many thanks

DezB

soccerfan

Put the users.php file in the same directory of the files you want protected.... hope it helps and doesn't hinder.

eberdome

NO NO NO! You must put the full path right before the /users.php

for example

WORKS-

home/abehs/public_html/users.php

DOESNT WORK-

http://www.example.com/users.php

tdeece

And how would one find out that full path?

I use FileZilla, know nothing about advanced programming stuff, it's just enough for HTML/CSS and following tutorials.

If "http://www.example.com" is not the full path, what is? Where can I find it? Somewhere in FileZilla? Somwhere in a properties tab maybe?

Thanks!

tdeece

Found it using a PHP script which told me the server path....
....still doesn't work :-(   wtf am I doing wrong?

it now says

$users = @file('/home/strato/www/ol/www.###.com/htdocs/main-dotcom/ppa/users.php' . USERS_LIST_FILE);

...

farhad


Found it using a PHP script which told me the server path....
....still doesn't work :-(   wtf am I doing wrong?

it now says

$users = @file('/home/strato/www/ol/www.###.com/htdocs/main-dotcom/ppa/users.php' . USERS_LIST_FILE);

...

it works:

$users = @file('/home/strato/www/ol/www.###.com/htdocs/main-dotcom/ppa/' . USERS_LIST_FILE);

i.e, without "users.php"