Zubrag.com
September 24, 2018, 11:55:07 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Email Account Creator Problem  (Read 11431 times)
smithster
Web Trade Pro
Newbie
*
Posts: 27


WWW
« on: March 17, 2007, 03:42:25 PM »

I love the idea behind all these scripts.  I'm having a problem with the email account creator script just now though.  Everything seams to work, I fill in the form, press submit, and it says email account created.  I login to CPanel to check and the email account hasn't been created.  I have checked all over the script and I cannot see any reason for this.  I tried out the script for creating a subdomain and this worked, although the output was really wierd looking!!

HTTP/1.0 200 OK Server: cpsrvd/10.9.6 Connection: close Date: Sat, 17 Mar 2007 16:41:16 -0500 Content-type: text/html Cache-Control: no-cache Pragma: no-cache cPanel X   Sub Domain Maintenance   SubDomain Creation Bind reloading on gator229 using rndc zone: [sc-clan.co.uk] The subdomain, test.sc-clan.co.uk has been added.     [ Go Back ] register_branding('branding-bg-top_01_bg'); register_branding('branding-img-top_01_1'); register_branding('branding-bg-top_01-sm_bg'); register_branding('branding-img-top_01-sm_1'); register_branding('branding-img-top_01-sm_2'); register_branding('branding-img-top_01-sm_3'); register_branding('branding-img-top_01-sm_4'); register_branding('branding-img-top_01-sm_5'); register_branding('branding-bg-top_03_bg'); register_branding('branding-img-top_03_1'); register_branding('branding-img-top_03_2'); register_branding('branding-bg-bottom_bg'); register_branding('branding-img-bottom_label'); register_branding('branding-img-home_on,home_off'); register_branding('branding-img-logout_on,logout_off');

Any ideas why I am having these problems?

Thanks for your help.

Paul.

Logged

S
zubrag
Administrator
Hero Member
*****
Posts: 788


WWW
« Reply #1 on: March 19, 2007, 07:41:36 AM »

Sorry, took long to respond.

Please replace following:
// Check result
while (!feof ($f)) {
  $line = fgets ($f, 1024);
  if (ereg ("already exists!", $line, $out)) {
    die('Such email account already exists.');
  }
}

with:

// Check result
while (!feof ($f)) {
  $line = fgets ($f, 1024);
  if (ereg ("already exists!", $line, $out)) {
    die('Such email account already exists.');
  }
  echo $line;
}

After this change run script again. It will output something. Please provide output here.
Logged
smithster
Web Trade Pro
Newbie
*
Posts: 27


WWW
« Reply #2 on: March 19, 2007, 07:27:20 PM »

Thank you for your reply.

The output has changed now.  Best way to describe it is to show you!

[edit] link removed to protect privacy [/edit]
Logged

S
smithster
Web Trade Pro
Newbie
*
Posts: 27


WWW
« Reply #3 on: March 19, 2007, 08:21:35 PM »

Ok, I have made some changes to the script and I got it working.  Only, I think I may have damadged the script!!  It does still work, but as you will see if you create an email account, the way it displays the user information just looks so wrong!!

I had to take chunks out of the script to get it at this stage, but maybe I have taken out too much.  Any ideas where I have gone wrong?

Thanks for your help.

Paul.
Logged

S
zubrag
Administrator
Hero Member
*****
Posts: 788


WWW
« Reply #4 on: March 20, 2007, 01:39:32 PM »

Removed link from your post to avoid illegal usage of that form by others.

Fixed.  Working script is on your server in the same folder: cmail.php

Can rename it to index.php if you want. Email quota can be set in the script, just update this line:     $equota = 20;
Logged
smithster
Web Trade Pro
Newbie
*
Posts: 27


WWW
« Reply #5 on: March 20, 2007, 02:40:24 PM »

Yeah got it, thanks very much for info, and will think twice before posting links on here again lol so thanks for the warning. Script works perfect too, thanks very much for your help
Logged

S
kahodges
Newbie
*
Posts: 1


« Reply #6 on: April 16, 2010, 08:33:35 PM »

I'm running into the same problem. This is the output I'm getting:

Warning: feof(): supplied argument is not a valid stream resource in /home/directory/public_html/directory/cpemail.php on line 108

Warning: fgets(): supplied argument is not a valid stream resource in /home/directory/public_html/directory/cpemail.php on line 109

I'd love to get this script running, help would be most appreciated.
Thanks.
Logged
wsimkins
Newbie
*
Posts: 1


« Reply #7 on: July 18, 2010, 10:59:05 AM »

Zubrag,

I am having the same issue as several others. I have yet to see you post a fix. When I create an email account it says created but does not exist in Cpanel.

I am trying to implement this in a password protected directory so our members can creat their own email accounts for personal use.

Can you email me please so I can get this fixed asap?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC